Typing in Workspace bug [FIXED]

(Read-only) To re-open a bug, start a new thread in the Bugs forum.

Moderator: MSandro

Locked
mguzdial
Posts: 70
Joined: Sep 15th, '15, 11:21

Typing in Workspace bug [FIXED]

Post by mguzdial » Jul 6th, '16, 20:30

I finally was able to capture a UI bug I've been facing for awhile.

I convert a stack of blocks to a text block and place the cursor in the middle of the word. (It only seems to happen in the middle of the word, not at the end of a word or when selecting a whole word with a double-click.)
Workspacebug1.png
Workspacebug1.png (10.41 KiB) Viewed 6597 times
Notice that the cursor is after the "f" in fftOfSamples.

Hit the delete key once.
Workspacebug2.png
Workspacebug2.png (9.86 KiB) Viewed 6597 times
The "O" disappears. The cursor still appears after the "f." If I keep hitting delete, the "t" of "fft" will disappear. It's always off-by-one.
Workspacebug3.png
Workspacebug3.png (10.29 KiB) Viewed 6597 times
But as I say, it's not consistent, so I always have to hit delete once cautiously, see what disappeared, and then continue or change my typing/replacing strategy.

JohnM
Posts: 379
Joined: Sep 11th, '15, 14:42

Re: Typing in Workspace bug

Post by JohnM » Jul 7th, '16, 13:36

Thank you for this excellent test case. I have also seen this problem, but I could never reproduce it reliably.

Starting with your example, I gradually removed blocks until I created a fairly small test case that reliably exhibits the problem:
Screen Shot 2016-07-07 at 9.33.03 AM.png
Screen Shot 2016-07-07 at 9.33.03 AM.png (17.5 KiB) Viewed 6593 times
After converting this to text and positioning the cursor as Mark describes, deleting is off by one.

(Jens, the "for" loop seems to be needed to re-create this problem, so the problem might have something to do with the handling of indentation when converting to text.)

Jens
Posts: 5
Joined: Sep 11th, '15, 02:26

Re: Typing in Workspace bug

Post by Jens » Jul 12th, '16, 08:32

Excellent test case, I can totally reproduce this bug, thanks for hunting it down, Mark and John. Working on a fix now...

JohnM
Posts: 379
Joined: Sep 11th, '15, 14:42

Re: Typing in Workspace bug

Post by JohnM » Aug 1st, '16, 14:40

Fixed in v54.

Locked